原题:
输入三个字符后,按各字符的ASCII码从小到大的顺序输出这三个字符。 |
Input
输入数据有多组,每组占一行,有三个字符组成,之间无空格。 Output
对于每组输入数据,输出一行,字符中间用一个空格分开。 Sample Input
qweasdzxc Sample Output
e q wa d sc x z 分析:大神都先从水题开始~
源码:
#include <iostream>
#include <algorithm>
usingnamespace std;
int main()
{
char n[4];
while (cin >> n)
{
if (n[0] > n[1]) swap(n[0], n[1]);
if (n[1] > n[2]) swap(n[1], n[2]);
if (n[0] > n[1]) swap(n[0], n[1]);
cout << n[0] << ' ' << n[1] << ' ' << n[2] << endl;
}
return 0;
}